GitHub Advisoryadvisory · Packagist
GHSA-jg4f-8w9x-jv35 Moodle Authenticated LFI risk in some misconfigured shared hosting environments
MEDIUM
Official page ↗
- Aliases
- CVE-2024-34003
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- Weaknesses
- CWE-200
- Reviewed
- 2024-06-04
Affected packages
• Packagist moodle/moodle: >= 4.3.0, < 4.3.4 → fixed in 4.3.4
• Packagist moodle/moodle: >= 4.2.0, < 4.2.7 → fixed in 4.2.7
• Packagist moodle/moodle: < 4.1.10 → fixed in 4.1.10
Description
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to restore workshop modules and direct access to the web server outside of the Moodle webroot could execute a local file include.
Related
Alias · CVE (1)
- CVE-2024-34003 In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness