GitHub Advisoryadvisory · PyPI

GHSA-jg4f-jqm5-4mgq Ansible fails to properly sanitize fact variables sent from the Ansible controller

CRITICAL Published 2018-10-10 Modified 2024-09-04 Official page ↗
Aliases
CVE-2016-8628
Ecosystem
PyPI
Packages
ansible
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2020-06-16

Affected packages

• PyPI ansible: < 2.2.0.0 → fixed in 2.2.0.0

Description

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.

Related

Alias · CVE (1)

  • CVE-2016-8628 Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References