GitHub Advisoryadvisory · Maven

GHSA-jgcr-9c2q-rvp8 Apache Struts is vulnerable to Cross-site Scripting

MEDIUM Published 2022-05-17 Modified 2024-02-09 Official page ↗
Aliases
CVE-2008-6682
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-02-09

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.0.0, < 2.0.11.1 → fixed in 2.0.11.1 • Maven org.apache.struts:struts2-core: >= 2.1.0, < 2.1.1 → fixed in 2.1.1

Description

Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.x before 2.0.11.1 and 2.1.x before 2.1.1 allow remote attackers to inject arbitrary web script or HTML via vectors associated with improper handling of (1) " (double quote) characters in the href attribute of an s:a tag and (2) parameters in the action attribute of an s:url tag.

Related

Alias · CVE (1)

  • CVE-2008-6682 Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.x before 2.0.11.1 and 2.1.x before 2.1.1 allow remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References