GitHub Advisoryadvisory · Maven
GHSA-jgpr-qrw2-6gp3 Exposure of Sensitive Information in Jenkins Core
MEDIUM
Official page ↗
- Aliases
- CVE-2016-0790
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2022-11-02
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 1.650 → fixed in 1.650
Description
Jenkins before 1.650 and LTS before 1.642.2 do not use a constant-time algorithm to verify API tokens, which makes it easier for remote attackers to determine API tokens via a brute-force approach.
Related
Alias · CVE (1)
- CVE-2016-0790 Jenkins before 1.650 and LTS before 1.642.2 do not use a constant-time algorithm to verify API tokens, which makes it easier for remote… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness