GitHub Advisoryadvisory · Maven

GHSA-jgwr-3qm3-26f3 Potential remote code execution in Apache Tomcat

HIGH Published 2021-03-19 Modified 2022-08-22 Official page ↗
Aliases
CVE-2021-25329
Ecosystem
Maven
Packages
org.apache.tomcat.embed:tomcat-embed-core
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2021-03-19

Affected packages

• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.0.0-M1, < 10.0.2 → fixed in 10.0.2 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0, < 9.0.41 → fixed in 9.0.41 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.0.0, < 8.5.61 → fixed in 8.5.61 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 7.0.0, < 7.0.108 → fixed in 7.0.108

Description

The fix for CVE-2020-9484 was incomplete. When using Apache Tomcat 10.0.0-M1 to 10.0.0, 9.0.0.M1 to 9.0.41, 8.5.0 to 8.5.61 or 7.0.0. to 7.0.107 with a configuration edge case that was highly unlikely to be used, the Tomcat instance was still vulnerable to CVE-2020-9494. Note that both the previously published prerequisites for CVE-2020-9484 and the previously published mitigations for CVE-2020-9484 also apply to this issue.

Related

Alias · CVE (1)

  • CVE-2021-25329 The fix for CVE-2020-9484 was incomplete. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References