GitHub Advisoryadvisory · npm
GHSA-jhgf-2h8h-ggxv Parse Server has a Cross-Site Scripting (XSS) vulnerability via Unescaped Mustache Template Variables
MEDIUM
Official page ↗
- Aliases
- CVE-2025-68115
- Ecosystem
- npm
- Packages
- parse-server
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-12-16
Affected packages
• npm parse-server: < 8.6.1 → fixed in 8.6.1
• npm parse-server: >= 9.0.0, < 9.1.0-alpha.3 → fixed in 9.1.0-alpha.3
Description
Impact
A Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages.
Patches
The patch escapes user controlled values that are inserted into the HTML pages.
Workarounds
None.
Resources
• https://github.com/parse-community/parse-server/security/advisories/GHSA-jhgf-2h8h-ggxv
• https://github.com/parse-community/parse-server/pull/9985
• https://github.com/parse-community/parse-server/pull/9986
Related
Alias · CVE (1)
- CVE-2025-68115 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-jhgf-2h8h-ggxv web
- https://nvd.nist.gov/vuln/detail/CVE-2025-68115 advisory
- https://github.com/parse-community/parse-server/pull/9985 web
- https://github.com/parse-community/parse-server/pull/9986 web
- https://github.com/parse-community/parse-server package