GitHub Advisoryadvisory · Packagist
GHSA-jhm9-h84h-rw83 phpBB Server-Side Request Forgery Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2020-8226
- Ecosystem
- Packagist
- Packages
- phpbb/phpbb
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- Weaknesses
- CWE-610, CWE-918
- Reviewed
- 2023-04-21
Affected packages
• Packagist phpbb/phpbb: >= 3.2.0, < 3.2.10 → fixed in 3.2.10
• Packagist phpbb/phpbb: >= 3.3.0, < 3.3.1 → fixed in 3.3.1
Description
A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF.
Related
Alias · CVE (1)
- CVE-2020-8226 A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-8226 advisory
- https://github.com/phpbb/phpbb-app/commit/0cfaaafb386d58576d200d56f1acdbcc2f2376e8 web
- https://github.com/phpbb/phpbb-app/commit/efc0a146bf12125eeb71d00470af774326a7bf0a web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpbb/phpbb/CVE-2020-8226.yaml web
- https://github.com/phpbb/phpbb-app package
- https://www.phpbb.com/community/viewtopic.php?f=14&t=2562631 web
- https://www.phpbb.com/community/viewtopic.php?f=14&t=2562636 web