GitHub Advisoryadvisory · RubyGems
GHSA-jjcj-fgfm-9g9r Phusion Passenger Race Condition Allows Privilege Escalation
HIGH
Official page ↗
- Aliases
- CVE-2018-12029
- Ecosystem
- RubyGems
- Packages
- passenger
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-362
- Reviewed
- 2023-06-09
Affected packages
• RubyGems passenger: >= 3.0.0, < 5.3.2 → fixed in 5.3.2
Description
A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a non-standard passenger_instance_registry_dir with insufficiently strict permissions is configured. Replacing a file with a symlink after the file was created, but before it was chowned, leads to the target of the link being chowned via the path. Targeting sensitive files such as root's crontab file allows privilege escalation.
Related
Alias · CVE (1)
- CVE-2018-12029 A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a… vulnerability
Weakness · CWE (1)
- CWE-362 Concurrent Execution using Shared Resource with Improper Synchronization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-12029 advisory
- https://blog.phusion.nl/2018/06/12/passenger-5-3-2-various-security-fixes web
- https://blog.phusion.nl/passenger-5-3-2 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/passenger/CVE-2018-12029.yml web
- https://lists.debian.org/debian-lts-announce/2018/06/msg00007.html web
- https://pulsesecurity.co.nz/advisories/phusion-passenger-priv-esc web
- https://security.gentoo.org/glsa/201807-02 web