GitHub Advisoryadvisory · Maven

GHSA-jjfh-589g-3hjx Spring Boot Actuator denial of service vulnerability

MEDIUM Published 2023-11-28 Modified 2025-02-13 Official page ↗
Aliases
CVE-2023-34055
Ecosystem
Maven
Packages
org.springframework.boot:spring-boot-actuator
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Reviewed
2023-11-28

Affected packages

• Maven org.springframework.boot:spring-boot-actuator: < 2.7.18 → fixed in 2.7.18 • Maven org.springframework.boot:spring-boot-actuator: >= 3.0.0, < 3.0.13 → fixed in 3.0.13 • Maven org.springframework.boot:spring-boot-actuator: >= 3.1.0, < 3.1.6 → fixed in 3.1.6

Description

In Spring Boot versions 2.7.0 - 2.7.17, 3.0.0-3.0.12 and 3.1.0-3.1.5, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: • the application uses Spring MVC or Spring WebFlux • `org.springframework.boot:spring-boot-actuator` is on the classpath

Related

Alias · CVE (1)

  • CVE-2023-34055 In Spring Boot versions 2.7.0 - 2.7.17, 3.0.0-3.0.12 and 3.1.0-3.1.5, it is possible for a user to provide specially crafted HTTP requests… vulnerability

References