GitHub Advisoryadvisory · Packagist

GHSA-jjhx-5jff-rc8m Moodle Improper Privilege Management

MEDIUM Published 2022-05-13 Modified 2023-10-31 Official page ↗
Aliases
CVE-2017-7532
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-269
Reviewed
2023-07-26

Affected packages

• Packagist moodle/moodle: >= 3.3.0, < 3.3.1 → fixed in 3.3.1 • Packagist moodle/moodle: >= 3.2.0, < 3.2.4 → fixed in 3.2.4 • Packagist moodle/moodle: < 3.1.7 → fixed in 3.1.7

Description

In Moodle 3.x, course creators are able to change system default settings for courses.

Related

Alias · CVE (1)

  • CVE-2017-7532 In Moodle 3.x, course creators are able to change system default settings for courses. vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References