GitHub Advisoryadvisory · Packagist

GHSA-jjx5-fq5g-8xpc Symfony Cryptographic Vulnerability

HIGH Published 2022-05-17 Modified 2024-02-08 Official page ↗
Aliases
CVE-2016-1902
Ecosystem
Packagist
Packages
symfony/security-core, symfony/security, symfony/symfony
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-332
Reviewed
2023-07-31

Affected packages

• Packagist symfony/security-core: >= 2.4.0, < 2.6.13 → fixed in 2.6.13 • Packagist symfony/security-core: >= 2.7.0, < 2.7.9 → fixed in 2.7.9 • Packagist symfony/security: >= 2.3.0, < 2.3.37 → fixed in 2.3.37 • Packagist symfony/security: >= 2.4.0, < 2.6.13 → fixed in 2.6.13 • Packagist symfony/security: >= 2.7.0, < 2.7.9 → fixed in 2.7.9 • Packagist symfony/symfony: >= 2.3.0, < 2.3.37 → fixed in 2.3.37 • Packagist symfony/symfony: >= 2.4.0, < 2.6.13 → fixed in 2.6.13 • Packagist symfony/symfony: >= 2.7.0, < 2.7.9 → fixed in 2.7.9

Description

The nextBytes function in the SecureRandom class in Symfony before 2.3.37, 2.6.x before 2.6.13, and 2.7.x before 2.7.9 does not properly generate random numbers when used with PHP 5.x without the paragonie/random_compat library and the openssl_random_pseudo_bytes function fails, which makes it easier for attackers to defeat cryptographic protection mechanisms via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2016-1902 The nextBytes function in the SecureRandom class in Symfony before 2.3.37, 2.6.x before 2.6.13, and 2.7.x before 2.7.9 does not properly… vulnerability

Weakness · CWE (1)

  • CWE-332 Insufficient Entropy in PRNG weakness

References