GitHub Advisoryadvisory · Packagist
GHSA-jjx7-8462-w4m4 Drupal Core Insufficient Contextual Links validation leads to Remote Code Execution
CRITICAL
Official page ↗
- Ecosystem
- Packagist
- Packages
- drupal/drupal
- Severity
- Critical
- Weaknesses
- CWE-20
- Reviewed
- 2024-05-15
Affected packages
• Packagist drupal/drupal: >= 8.0.0, < 8.5.8 → fixed in 8.5.8
• Packagist drupal/drupal: >= 8.6.0, < 8.6.2 → fixed in 8.6.2
Description
The Contextual Links module doesn't sufficiently validate the requested contextual links.
This vulnerability is mitigated by the fact that an attacker must have a role with the permission "access contextual links".
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness