GitHub Advisoryadvisory · Packagist

GHSA-jm6m-4632-36hf Composer Remote Code Execution vulnerability via web-accessible composer.phar

HIGH Published 2023-09-29 Modified 2025-02-13 Official page ↗
Aliases
CVE-2023-43655
Ecosystem
Packagist
Packages
composer/composer
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-74
Reviewed
2023-09-29

Affected packages

• Packagist composer/composer: < 1.10.27 → fixed in 1.10.27 • Packagist composer/composer: >= 2.0.0, < 2.2.22 → fixed in 2.2.22 • Packagist composer/composer: >= 2.3.0, < 2.6.4 → fixed in 2.6.4

Description

Impact Users publishing a composer.phar to a public web-accessible server where the composer.phar can be executed as a php file may be impacted if PHP also has `register_argc_argv` enabled in php.ini. Patches 2.6.4, 2.2.22 and 1.10.27 patch this vulnerability. Workarounds Make sure `register_argc_argv` is disabled in php.ini, and avoid publishing composer.phar to the web as this really should not happen.

Related

Alias · CVE (1)

  • CVE-2023-43655 Composer is a dependency manager for PHP. vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References