GitHub Advisoryadvisory · PyPI
GHSA-jm77-qphf-c4w8 pyca/cryptography's wheels include vulnerable OpenSSL
LOW
Official page ↗
- Ecosystem
- PyPI
- Packages
- cryptography
- Severity
- Low
- Reviewed
- 2023-08-01
Affected packages
• PyPI cryptography: >= 0.8, < 41.0.3 → fixed in 41.0.3
Description
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.8-41.0.2 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230731.txt, https://www.openssl.org/news/secadv/20230719.txt, and https://www.openssl.org/news/secadv/20230714.txt.
If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
References
- https://github.com/pyca/cryptography/security/advisories/GHSA-jm77-qphf-c4w8 web
- https://github.com/pyca/cryptography/commit/b22271cf3c3dd8dc8978f8f4b00b5c7060b6538d web
- https://github.com/pyca/cryptography/commit/bfa4d95f0f356f2d535efd5c775e0fb3efe90ef2 web
- https://github.com/pyca/cryptography package
- https://www.openssl.org/news/secadv/20230714.txt web
- https://www.openssl.org/news/secadv/20230719.txt web
- https://www.openssl.org/news/secadv/20230731.txt web