GitHub Advisoryadvisory · RubyGems
GHSA-jm79-9pm4-vrw9 Decidim vulnerable to sensitive data disclosure
HIGH
Official page ↗
- Aliases
- CVE-2023-34090
- Ecosystem
- RubyGems
- Packages
- decidim, decidim-meetings
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2023-07-11
Affected packages
• RubyGems decidim: >= 0.27.0, < 0.27.3 → fixed in 0.27.3
• RubyGems decidim-meetings: >= 0.27.0, < 0.27.3 → fixed in 0.27.3
Description
Note: added the actual report as a comment.
Summary
Decidim, a platform for digital citizen participation, uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table).
Impact
This issue may lead to Sensitive Data Disclosure.
Patches
The problem was patched in v0.27.3.
Workarounds
Disable or unpublish all meetings components from your application.
Related
Alias · CVE (1)
- CVE-2023-34090 Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://github.com/decidim/decidim/security/advisories/GHSA-jm79-9pm4-vrw9 web
- https://github.com/decidim/decidim/security/advisories/GHSA-jm79-9pm4-vrw9#advisory-comment-81110 web
- https://nvd.nist.gov/vuln/detail/CVE-2023-34090 advisory
- https://github.com/decidim/decidim package
- https://github.com/decidim/decidim/releases/tag/v0.27.3 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-meetings/CVE-2023-34090.yml web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2023-34090.yml web