GitHub Advisoryadvisory · PyPI
GHSA-jm9x-rx9x-wpqj OAuth2 client ID and secret exposed through the web browser
HIGH
Official page ↗
- Aliases
- CVE-2024-9014
- Ecosystem
- PyPI
- Packages
- pgadmin4
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2024-10-01
Affected packages
• PyPI pgadmin4: < 8.12 → fixed in 8.12
Description
pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.
Related
Alias · CVE (1)
- CVE-2024-9014 pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness