GitHub Advisoryadvisory · Maven
GHSA-jmf4-pq78-f8vj Moderate severity vulnerability that affects org.apache.hive:hive-jdbc
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1314
- Ecosystem
- Maven
- Packages
- org.apache.hive:hive-jdbc
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-862
- Reviewed
- 2020-06-16
Affected packages
• Maven org.apache.hive:hive-jdbc: < 2.3.4 → fixed in 2.3.4
• Maven org.apache.hive:hive-jdbc: >= 3.0.0, < 3.1.1 → fixed in 3.1.1
Description
In Apache Hive 2.3.3, 3.1.0 and earlier, Hive "EXPLAIN" operation does not check for necessary authorization of involved entities in a query. An unauthorized user can do "EXPLAIN" on arbitrary table or view and expose table metadata and statistics.
Related
Alias · CVE (1)
- CVE-2018-1314 In Apache Hive 2.3.3, 3.1.0 and earlier, Hive "EXPLAIN" operation does not check for necessary authorization of involved entities in a… vulnerability
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness