GitHub Advisoryadvisory · Maven

GHSA-jmg4-x4vp-6c6x Apache Geode vulnerable to Incorrect Authorization

HIGH Published 2022-05-13 Modified 2024-04-12 Official page ↗
Aliases
CVE-2017-15695
Ecosystem
Maven
Packages
org.apache.geode:geode-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-863
Reviewed
2022-11-08

Affected packages

• Maven org.apache.geode:geode-core: >= 1.0.0, < 1.5.0 → fixed in 1.5.0

Description

When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.

Related

Alias · CVE (1)

  • CVE-2017-15695 When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References