GitHub Advisoryadvisory · RubyGems

GHSA-jmgw-6vjg-jjwg actionpack Improper Input Validation vulnerability

HIGH Published 2017-10-24 Modified 2023-02-15 Official page ↗
Aliases
CVE-2013-0156
Ecosystem
RubyGems
Packages
actionpack
Severity
High
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: < 2.3.15 → fixed in 2.3.15 • RubyGems actionpack: >= 3.0.0, < 3.0.19 → fixed in 3.0.19 • RubyGems actionpack: >= 3.1.0, < 3.1.10 → fixed in 3.1.10 • RubyGems actionpack: >= 3.2.0, < 3.2.11 → fixed in 3.2.11

Description

`active_support/core_ext/hash/conversions.rb` in Ruby on Rails before 2.3.15, 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion.

Related

Alias · CVE (1)

  • CVE-2013-0156 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References