GitHub Advisoryadvisory · Packagist
GHSA-jmh9-6rjq-gjh9 Vulnerable embedded jQuery Version
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- pimcore/admin-ui-classic-bundle
- Severity
- Moderate
- Reviewed
- 2024-06-05
Affected packages
• Packagist pimcore/admin-ui-classic-bundle: < 1.4.3 → fixed in 1.4.3
Description
Summary
PIMCore uses the JavaScript library jQuery in version 3.4.1. This version is vulnerable to cross-site-scripting (XSS).
Details
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
Publish Date: 2020-04-29
URL:= https://security.snyk.io/package/npm/jquery/3.4.1