GitHub Advisoryadvisory · RubyGems
GHSA-jmm9-2p29-vh2w activerecord vulnerable to SQL Injection
HIGH
Official page ↗
- Aliases
- CVE-2011-0448
- Ecosystem
- RubyGems
- Packages
- activerecord
- Severity
- High
- Weaknesses
- CWE-89
- Reviewed
- 2020-06-16
Affected packages
• RubyGems activerecord: >= 3.0.0, < 3.0.4 → fixed in 3.0.4
Description
Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.
Related
Alias · CVE (1)
- CVE-2011-0448 Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for… vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-0448 advisory
- https://github.com/rails/rails/commit/354da43ab0a10b3b7b3f9cb0619aa562c3be8474 web
- https://github.com/rails/rails package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2011-0448.yml web
- https://web.archive.org/web/20201220214809/http://securitytracker.com/id?1025063 web
- http://groups.google.com/group/rubyonrails-security/msg/4e19864cf6ad40ad?dmode=source&output=gplain web
- http://lists.fedoraproject.org/pipermail/package-announce/2011-April/057650.html web
- http://weblog.rubyonrails.org/2011/2/8/new-releases-2-3-11-and-3-0-4 web