GitHub Advisoryadvisory · Packagist
GHSA-jmq3-x8q7-j9qm baserCMS has a cross-site scripting vulnerability in blog posts
MEDIUM
Official page ↗
- Aliases
- CVE-2026-30879
- Ecosystem
- Packagist
- Packages
- baserproject/basercms
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- Weaknesses
- CWE-79
- Reviewed
- 2026-03-31
Affected packages
• Packagist baserproject/basercms: < 5.2.3 → fixed in 5.2.3
Description
baserCMS has a cross-site scripting vulnerability in blog posts.
Target
baserCMS 5.2.1 and earlier versions
Vulnerability
Malicious Javascript may be executed in blog posts.
Countermeasures
Update to the latest version of baserCMS
Please refer to the following page to reference for more information.
https://basercms.net/security/JVN_20837860
Credits
Gai Tanaka@Mitsui Bussan Secure Directions, Inc.
Related
Alias · CVE (1)
- CVE-2026-30879 baserCMS is a website development framework. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness