GitHub Advisoryadvisory · Go
GHSA-jmvr-r5hm-fxfr Mattermost doesn't enforce request body size limits on plugin HTTP endpoints
HIGH
Official page ↗
- Aliases
- CVE-2026-5308
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-plugin-github
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2026-06-29
Affected packages
• Go github.com/mattermost/mattermost-server: >= 11.6.0, < 11.6.1 → fixed in 11.6.1
• Go github.com/mattermost/mattermost-server: >= 11.5.0, < 11.5.4 → fixed in 11.5.4
• Go github.com/mattermost/mattermost-server: >= 11.4.0, < 11.4.5 → fixed in 11.4.5
• Go github.com/mattermost/mattermost-server: >= 10.11.0, < 10.11.15 → fixed in 10.11.15
• Go github.com/mattermost/mattermost-plugin-github: < 1.0.1-0.20260410143745-9b41b1fd43c4 → fixed in 1.0.1-0.20260410143745-9b41b1fd43c4
Description
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to enforce request body size limits on plugin HTTP endpoints which allows an attacker to cause a denial of service via crafted oversized HTTP requests.. Mattermost Advisory ID: MMSA-2026-00646
Related
Alias · CVE (1)
- CVE-2026-5308 Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to enforce request body size limits on… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness