GitHub Advisoryadvisory · Go
GHSA-jp57-4x34-5v94 Mattermost Server is vulnerable to webhook and slash command manipulation
MEDIUM
Official page ↗
- Aliases
- CVE-2017-18889
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2025-12-05
Affected packages
• Go github.com/mattermost/mattermost-server: < 4.1.2 → fixed in 4.1.2
• Go github.com/mattermost/mattermost-server: >= 4.2.0-rc1, < 4.2.1 → fixed in 4.2.1
• Go github.com/mattermost/mattermost-server: >= 4.3.0-rc1, < 4.3.0 → fixed in 4.3.0
Description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. An attacker could create fictive system-message posts via webhooks and slash commands, in the v3 or v4 REST API.
Related
Alias · CVE (1)
- CVE-2017-18889 An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness