GitHub Advisoryadvisory · npm
GHSA-jp6r-xcjj-5h7r Cross-Site Scripting in cyberchef
MEDIUM
Official page ↗
- Aliases
- CVE-2019-15532
- Ecosystem
- npm
- Packages
- cyberchef
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2019-08-27
Affected packages
• npm cyberchef: < 8.31.3 → fixed in 8.31.3
Description
Versions of `cyberchef` prior to 8.31.3 are vulnerable to Cross-Site Scripting. In `Text Encoding Brute Force` the table rows are created by concatenating the `value` variable unsanitized in the HTML code. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser.
Recommendation
Upgrade to version 8.31.3 or later.
Related
Alias · CVE (1)
- CVE-2019-15532 CyberChef before 8.31.2 allows XSS in core/operations/TextEncodingBruteForce.mjs. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-15532 advisory
- https://github.com/gchq/CyberChef/issues/539 web
- https://github.com/gchq/CyberChef/issues/544 web
- https://github.com/gchq/CyberChef/commit/01f0625d6a177f9c5df9281f12a27c814c2d8bcf web
- https://github.com/gchq/CyberChef/compare/v8.31.1...v8.31.2 web
- https://snyk.io/vuln/SNYK-JS-CYBERCHEF-460296 web
- https://www.npmjs.com/advisories/1149 web