GitHub Advisoryadvisory · Packagist

GHSA-jpf2-9ppp-2c49 Moodle has insufficient access control

LOW Published 2024-11-11 Modified 2024-11-12 Official page ↗
Aliases
CVE-2024-43430
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-276
Reviewed
2024-11-12

Affected packages

• Packagist moodle/moodle: >= 4.4.0, < 4.4.2 → fixed in 4.4.2

Description

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-276 Incorrect Default Permissions weakness

References