GitHub Advisoryadvisory · Maven
GHSA-jphj-5g3m-w7x6 Ignite Realtime Openfire vulnerable to cross-site scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2018-11688
- Ecosystem
- Maven
- Packages
- org.igniterealtime.openfire:parent
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-11-22
Affected packages
• Maven org.igniterealtime.openfire:parent: < 3.9.2 → fixed in 3.9.2
Description
Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
Related
Alias · CVE (1)
- CVE-2018-11688 Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-11688 advisory
- https://github.com/igniterealtime/Openfire/commit/ed3492a24274fd454afe93a499db49f3d6335108#diff-3f607cf668ad8f1091e789a2c1dca32a web
- https://github.com/igniterealtime/Openfire package
- https://github.com/igniterealtime/Openfire/compare/v3.9.1...v3.9.2 web
- https://vulmon.com/vulnerabilitydetails?qid=CVE-2018-11688 web
- http://packetstormsecurity.com/files/148057/Ignite-Realtime-Openfire-3.7.1-Cross-Site-Scripting.html web
- http://seclists.org/fulldisclosure/2018/Jun/13 web
- http://seclists.org/fulldisclosure/2018/Jun/24 web
- http://www.securityfocus.com/archive/1/542060/100/0/threaded web