GitHub Advisoryadvisory · npm
GHSA-jpvj-wpmj-h7rv Supply chain compromise via malicious @cap-js/openapi
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- @cap-js/openapi
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-506
- Reviewed
- 2026-06-04
Affected packages
• npm @cap-js/openapi: >= 1.4.1, < 1.4.2 → fixed in 1.4.2
Description
Impact
On May 19, 2026, a compromised version of @cap-js/[email protected] was published.
The malicious packages harvested credentials and attempted self-propagation.
If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised.
Patches
Upgrade to @cap-js/openapi >= 1.4.2
If the compromised version was ever installed, rotate all affected credentials.
Workarounds
No workarounds.
References
• SAP Note 3747787
• Developer FAQ
Related
Weakness · CWE (1)
- CWE-506 Embedded Malicious Code weakness