GitHub Advisoryadvisory · Maven

GHSA-jq2w-w7v2-69q5 Apache Solr vulnerable to XML Bomb

HIGH Published 2022-05-24 Modified 2023-03-06 Official page ↗
Aliases
CVE-2019-12401
Ecosystem
Maven
Packages
org.apache.solr:solr-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-776
Reviewed
2022-11-08

Affected packages

• Maven org.apache.solr:solr-core: < 5.0.0 → fixed in 5.0.0

Description

Solr versions prior to 5.0.0 are vulnerable to an XML resource consumption attack (a.k.a. Lol Bomb) via it?s update handler.?By leveraging XML DOCTYPE and ENTITY type elements, the attacker can create a pattern that will expand when the server parses the XML causing OOMs.

Related

Alias · CVE (1)

  • CVE-2019-12401 Solr versions 1.3.0 to 1.4.1, 3.1.0 to 3.6.2 and 4.0.0 to 4.10.4 are vulnerable to an XML resource consumption attack (a.k.a. vulnerability

Weakness · CWE (1)

  • CWE-776 Improper Restriction of Recursive Entity References in DTDs weakness

References