GitHub Advisoryadvisory · Go

GHSA-jq9f-gm9w-rwm9 OpenFGA Improper Policy Enforcement

MEDIUM Published 2026-02-05 Modified 2026-02-06 Official page ↗
Aliases
CVE-2026-24851
Ecosystem
Go
Packages
github.com/openfga/openfga
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
Weaknesses
CWE-863
Reviewed
2026-02-05

Affected packages

• Go github.com/openfga/openfga: >= 1.8.5, < 1.11.3 → fixed in 1.11.3

Description

Impact OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22 <= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed. Affected Users Users are affected by this vulnerability if all of the following preconditions are met: • OpenFGA v1.8.5 to v1.11.2 is being used • The model has a relation directly assignable by a type bound public access and assignable by type bound non-public access • A tuple is assigned for the relation that is a type bound public access • A tuple is assigned for the same object with the same relation that is not type bound public access • A tuple is assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access Fix Upgrade to v1.11.3. This upgrade is backwards compatible. Workaround None

Related

Alias · CVE (1)

  • CVE-2026-24851 OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References