GitHub Advisoryadvisory · Packagist
GHSA-jqgr-gh62-jf53 Moodle Stored Cross-site Scripting and page denial of service
HIGH
Official page ↗
- Aliases
- CVE-2022-40313
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.9, < 3.9.17 → fixed in 3.9.17
• Packagist moodle/moodle: >= 3.11, < 3.11.10 → fixed in 3.11.10
• Packagist moodle/moodle: >= 4.0, < 4.0.4 → fixed in 4.0.4
Description
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an Cross-site Scripting risk or a page failing to load.
Related
Alias · CVE (1)
- CVE-2022-40313 Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness