GitHub Advisoryadvisory · npm
GHSA-jqh7-w5pr-cr56 Cross-site scripting in @shopify/koa-shopify-auth
MEDIUM
Official page ↗
- Aliases
- CVE-2020-8176
- Ecosystem
- npm
- Packages
- @shopify/koa-shopify-auth
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-05-11
Affected packages
• npm @shopify/koa-shopify-auth: >= 3.1.61, < 3.1.63 → fixed in 3.1.63
Description
A cross-site scripting vulnerability exists in koa-shopify-auth v3.1.61-v3.1.62 that allows an attacker to inject JS payloads into the `shop` parameter on the `/shopify/auth/enable_cookies` endpoint.
Related
Alias · CVE (1)
- CVE-2020-8176 A cross-site scripting vulnerability exists in koa-shopify-auth v3.1.61-v3.1.62 that allows an attacker to inject JS payloads into the… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness