GitHub Advisoryadvisory · npm

GHSA-jqhq-pfg3-fg5p Blink1Control2 uses weak password encryption

HIGH Published 2022-09-08 Modified 2022-09-16 Official page ↗
Aliases
CVE-2022-35513
Ecosystem
npm
Packages
Blink1Control2
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-326
Reviewed
2022-09-16

Affected packages

• npm Blink1Control2: < 2.2.9 → fixed in 2.2.9

Description

The Blink1Control2 application <= 2.2.7 uses weak password encryption and an insecure method of storage. Version 2.2.9 fixes the issue.

Related

Alias · CVE (1)

  • CVE-2022-35513 The Blink1Control2 application <= 2.2.7 uses weak password encryption and an insecure method of storage. vulnerability

Weakness · CWE (1)

  • CWE-326 Inadequate Encryption Strength weakness

References