GitHub Advisoryadvisory · Packagist

GHSA-jqmr-wqgp-8mh2 phpMyAdmin cross-site scripting Vulnerability in Table or Column Names

LOW Published 2022-05-17 Modified 2023-08-16 Official page ↗
Aliases
CVE-2014-4986
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Low
Weaknesses
CWE-79
Reviewed
2023-08-16

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.0.0, < 4.0.10.1 → fixed in 4.0.10.1 • Packagist phpmyadmin/phpmyadmin: >= 4.1.0, < 4.1.14.2 → fixed in 4.1.14.2 • Packagist phpmyadmin/phpmyadmin: >= 4.2.0, < 4.2.6 → fixed in 4.2.6

Description

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Related

Alias · CVE (1)

  • CVE-2014-4986 Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References