GitHub Advisoryadvisory · npm

GHSA-jrqm-vmqc-gm93 CKEditor 5 has Cross-site Scripting (XSS) in the HTML Support package

MEDIUM Published 2026-03-04 Modified 2026-03-19 Official page ↗
Aliases
CVE-2026-28343
Ecosystem
npm
Packages
@ckeditor/ckeditor5-html-support, ckeditor5
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2026-03-04

Affected packages

• npm @ckeditor/ckeditor5-html-support: >= 29.0.0, < 47.6.0 → fixed in 47.6.0 • npm ckeditor5: >= 29.0.0, < 47.6.0 → fixed in 47.6.0

Description

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This vulnerability affects only installations where the editor configuration meets the following criteria: • General HTML Support is enabled, • General HTML Support configuration allows inserting unsafe markup (see Security section to learn more). Patches The problem has been recognized and patched. The fix will be available in version 47.6.0 (and above). Workarounds CKEditor 5 recommends configuring General HTML Support securely to ensure that unsafe content is not accepted. Please refer to the Security section for detailed guidance. Credits CKEditor 5 would like to thank: • Emilio Kevin • Jeongwoo Lee, Younsoung Kim, Minseok Kim and Jinyeong Kim from ENKI Whitehat for responsibly reporting this vulnerability. For more information Email us at [email protected] if you have any questions or comments about this advisory.

Related

Alias · CVE (1)

  • CVE-2026-28343 CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References