GitHub Advisoryadvisory · RubyGems

GHSA-jvgm-pfqv-887x Bundler allows attacker to inject arbitrary code via secondary Gem source

CRITICAL Published 2022-05-14 Modified 2025-04-14 Official page ↗
Aliases
CVE-2016-7954
Ecosystem
RubyGems
Packages
bundler
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-06-23

Affected packages

• RubyGems bundler: >= 1.0.0, < 2.0.0 → fixed in 2.0.0

Description

Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.

Related

Alias · CVE (1)

  • CVE-2016-7954 Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References