GitHub Advisoryadvisory · Maven
GHSA-jvv4-8wxx-m5r6 Apache Wicket has an Exposure of Sensitive Information to an Unauthorized Actor vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2026-43646
- Ecosystem
- Maven
- Packages
- org.apache.wicket:wicket-parent
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2026-05-11
Affected packages
• Maven org.apache.wicket:wicket-parent: >= 8.0.0-M1, <= 8.17.0 (no fix yet)
• Maven org.apache.wicket:wicket-parent: >= 9.0.0-M1, <= 9.22.0 (no fix yet)
• Maven org.apache.wicket:wicket-parent: >= 10.0.0-M1, < 10.9.0 → fixed in 10.9.0
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2026-43646 Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness