GitHub Advisoryadvisory · crates.io
GHSA-jw36-hf63-69r9 `libsqlite3-sys` via C SQLite improperly validates array index
HIGH
Official page ↗
- Aliases
- CVE-2022-35737
- Ecosystem
- crates.io
- Packages
- libsqlite3-sys
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-129
- Reviewed
- 2023-02-15
Affected packages
• crates.io libsqlite3-sys: < 0.25.1 → fixed in 0.25.1
Description
SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API.
Related
Alias · CVE (1)
- CVE-2022-35737 SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to… vulnerability
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-35737 advisory
- https://blog.trailofbits.com/2022/10/25/sqlite-vulnerability-july-2022-library-api web
- https://github.com/rusqlite/rusqlite package
- https://kb.cert.org/vuls/id/720344 web
- https://rustsec.org/advisories/RUSTSEC-2022-0090.html web
- https://security.gentoo.org/glsa/202210-40 web
- https://security.netapp.com/advisory/ntap-20220915-0009 web
- https://sqlite.org/releaselog/3_39_2.html web
- https://www.sqlite.org/cves.html web