GitHub Advisoryadvisory · Packagist

GHSA-jw6x-4h8h-569x Roots Soil plugin vulnerable to Cross-site Scripting

MEDIUM Published 2022-12-15 Modified 2022-12-21 Official page ↗
Aliases
CVE-2022-4524
Ecosystem
Packagist
Packages
roots/soil
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-12-15

Affected packages

• Packagist roots/soil: < 4.1.0 → fixed in 4.1.0

Description

A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.1.0. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.1 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.

Related

Alias · CVE (1)

  • CVE-2022-4524 A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References