GitHub Advisoryadvisory · PyPI

GHSA-jw8x-6495-233v scikit-learn sensitive data leakage vulnerability

MEDIUM Published 2024-06-06 Modified 2024-10-25 Official page ↗
Aliases
CVE-2024-5206
Ecosystem
PyPI
Packages
scikit-learn
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-921, CWE-922
Reviewed
2024-06-17

Affected packages

• PyPI scikit-learn: < 1.5.0 → fixed in 1.5.0

Description

A sensitive data leakage vulnerability was identified in scikit-learn's TfidfVectorizer, specifically in versions up to and including 1.4.1.post1, which was fixed in version 1.5.0. The vulnerability arises from the unexpected storage of all tokens present in the training data within the `stop_words_` attribute, rather than only storing the subset of tokens required for the TF-IDF technique to function. This behavior leads to the potential leakage of sensitive information, as the `stop_words_` attribute could contain tokens that were meant to be discarded and not stored, such as passwords or keys. The impact of this vulnerability varies based on the nature of the data being processed by the vectorizer.

Related

Alias · CVE (1)

  • CVE-2024-5206 A sensitive data leakage vulnerability was identified in scikit-learn's TfidfVectorizer, specifically in versions up to and including… vulnerability

Weakness · CWE (2)

  • CWE-921 Storage of Sensitive Data in a Mechanism without Access Control weakness
  • CWE-922 Insecure Storage of Sensitive Information weakness

References