GitHub Advisoryadvisory · RubyGems

GHSA-jw9c-mfg7-9rx2 SAML authentication bypass via Incorrect XPath selector

CRITICAL Published 2024-09-10 Modified 2026-06-08 Official page ↗
Aliases
CVE-2024-45409
Ecosystem
RubyGems
Packages
ruby-saml
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
Weaknesses
CWE-347
Reviewed
2024-09-10

Affected packages

• RubyGems ruby-saml: < 1.12.3 → fixed in 1.12.3 • RubyGems ruby-saml: >= 1.13.0, < 1.17.0 → fixed in 1.17.0

Description

Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability was reported by ahacker1 of SecureSAML ([email protected])

Related

Alias · CVE (1)

  • CVE-2024-45409 The Ruby SAML library is for implementing the client side of a SAML authorization. vulnerability

Weakness · CWE (1)

  • CWE-347 Improper Verification of Cryptographic Signature weakness

References