GitHub Advisoryadvisory · RubyGems

GHSA-jw9f-hh49-cvp9 Nokogiri contains libxml Out-of-bounds Write vulnerability

HIGH Published 2022-05-24 Modified 2023-08-28 Official page ↗
Aliases
CVE-2021-3517
Ecosystem
RubyGems
Packages
nokogiri
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
Weaknesses
CWE-787
Reviewed
2023-03-08

Affected packages

• RubyGems nokogiri: < 1.11.4 → fixed in 1.11.4

Description

There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application. Nokogiri prior to version 1.11.4 used a vulnerable version of libxml2. Nokogiri 1.11.4 updated libxml2 to version 2.9.11 to address this and other vulnerabilities in libxml2.

Related

Alias · CVE (1)

  • CVE-2021-3517 There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. vulnerability

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References