GitHub Advisoryadvisory · Maven
GHSA-jwr6-75xh-jh5j Synopsys Jenkins Coverity Plugin has Incorrect Default Permissions
MEDIUM
Official page ↗
- Aliases
- CVE-2023-23850
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:synopsys-coverity
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-276
- Reviewed
- 2023-02-23
Affected packages
• Maven org.jenkins-ci.plugins:synopsys-coverity: < 3.0.3 → fixed in 3.0.3
Description
Synopsys Coverity Plugin 3.0.2 and earlier does not perform permission checks in several HTTP endpoints.
This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability.
An enumeration of credentials IDs in Synopsys Coverity Plugin 3.0.3 requires the appropriate permissions.
Related
Alias · CVE (1)
- CVE-2023-23850 A missing permission check in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers with Overall/Read permission to enumerate… vulnerability
Weakness · CWE (1)
- CWE-276 Incorrect Default Permissions weakness