GitHub Advisoryadvisory · Packagist
GHSA-jwxh-wj79-ccm6 Magento Reflected Cross-site Scripting vulnerability via 'file' parameter
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21029
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-01-11
Affected packages
• Packagist magento/community-edition: < 2.3.6-p1 → fixed in 2.3.6-p1
• Packagist magento/community-edition: >= 2.4.0, < 2.4.2 → fixed in 2.4.2
Description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.
Related
Alias · CVE (1)
- CVE-2021-21029 Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21029 advisory
- https://github.com/magento/magento2/commit/a2eb7e29ea92a8bbc86c3b6b81b59d8533088497 web
- https://github.com/magento/magento2/commit/a349e022c9ae070e7da262021f9ef182105aa00b web
- https://github.com/magento/magento2 package
- https://helpx.adobe.com/security/products/magento/apsb21-08.html web