GitHub Advisoryadvisory · PyPI

GHSA-jx3q-5rgf-vrrr xalpha vulnerable to Remote Code Execution

CRITICAL Published 2023-07-11 Modified 2024-11-19 Official page ↗
Aliases
CVE-2023-37659
Ecosystem
PyPI
Packages
xalpha
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-07-11

Affected packages

• PyPI xalpha: >= 0.11.4, < 0.11.9 → fixed in 0.11.9

Description

xalpha v0.11.4 is vulnerable to Remote Command Execution (RCE). User input is not properly checked to be numerical values prior to being evaluated.

Related

Alias · CVE (1)

  • CVE-2023-37659 xalpha v0.11.4 is vulnerable to Remote Command Execution (RCE). vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References