GitHub Advisoryadvisory · npm
GHSA-jxf5-7x3j-8j9m Malicious Package in load-from-cwd-or-npm
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- load-from-cwd-or-npm
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506
- Reviewed
- 2020-08-31
Affected packages
• npm load-from-cwd-or-npm: >= 3.0.2, < 3.0.4 → fixed in 3.0.4
Description
Version 3.0.2 of `load-from-cwd-or-npm` contains malicious code. The malware breaks functionality of the `purescript-installer` package by injecting targeted code.
Recommendation
Upgrade to version 3.0.4 or later. There is no indication of further compromise.
Related
Weakness · CWE (1)
- CWE-506 Embedded Malicious Code weakness