GitHub Advisoryadvisory · RubyGems

GHSA-jxx8-v83v-rhw3 Spree Improper Input Validation vulnerability

MEDIUM Published 2017-10-24 Modified 2023-08-29 Official page ↗
Aliases
CVE-2013-1656
Ecosystem
RubyGems
Packages
spree
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems spree: >= 1.0.0, < 2.0.0.rc1 → fixed in 2.0.0.rc1

Description

Spree Commerce 1.0.x before 2.0.0.rc1 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary commands via the (1) `payment_method` parameter to `core/app/controllers/spree/admin/payment_methods_controller.rb`; and the (2) `promotion_action parameter` to `promotion_actions_controller.rb`, (3) `promotion_rule parameter` to `promotion_rules_controller.rb`, and (4) `calculator_type` parameter to `promotions_controller.rb` in `promo/app/controllers/spree/admin/`, related to unsafe use of the constantize function.

Related

Alias · CVE (1)

  • CVE-2013-1656 Spree Commerce 1.0.x through 1.3.2 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References