GitHub Advisoryadvisory · Packagist
GHSA-m2p5-fwp2-qcw2 Yii Framework Code Injection
HIGH
Official page ↗
- Aliases
- CVE-2018-8074
- Ecosystem
- Packagist
- Packages
- yiisoft/yii2-dev, yiisoft/yii2-elasticsearch
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2023-07-20
Affected packages
• Packagist yiisoft/yii2-dev: >= 2.0.0, < 2.0.15 → fixed in 2.0.15
• Packagist yiisoft/yii2-elasticsearch: < 2.0.5 → fixed in 2.0.5
Description
Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.
Related
Alias · CVE (1)
- CVE-2018-8074 Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-8074 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2-elasticsearch/CVE-2018-8074.yaml web
- https://github.com/yiisoft/yii2 package
- https://www.yiiframework.com/news/168/releasing-yii-2-0-15-and-database-extensions-with-security-fixes web
- http://www.yiiframework.com/news/168/releasing-yii-2-0-15-and-database-extensions-with-security-fixes web