GitHub Advisoryadvisory · Go

GHSA-m2w9-h2mm-79qr Mattermost doesn't require system-level permission when patching protected default system roles

MEDIUM Published 2026-06-12 Modified 2026-08-24 Official page ↗
Aliases
CVE-2026-6739
Ecosystem
Go
Packages
github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L
Weaknesses
CWE-863
Reviewed
2026-08-24

Affected packages

• Go github.com/mattermost/mattermost-server: >= 11.6.0, < 11.6.1 → fixed in 11.6.1 • Go github.com/mattermost/mattermost-server: >= 11.5.0, < 11.5.5 → fixed in 11.5.5 • Go github.com/mattermost/mattermost-server: >= 10.11.0, < 10.11.17 → fixed in 10.11.17 • Go github.com/mattermost/mattermost/server/v8: >= 8.0.0-20250731163400-5b955468ea1e, < 8.0.0-20260501142004-99b73d4c4acf → fixed in 8.0.0-20260501142004-99b73d4c4acf

Description

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to require system-level permission when patching protected default system roles, which allows authenticated users with delegated user-management permissions to escalate privileges by altering built-in role permissions via the role patch API. Mattermost Advisory ID: MMSA-2026-00656

Related

Alias · CVE (1)

  • CVE-2026-6739 Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to require system-level permission… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References