GitHub Advisoryadvisory · Packagist
GHSA-m2ww-6wv6-vw3c Cross site scripting in Concrete CMS
LOW
Official page ↗
- Aliases
- CVE-2022-30120
- Ecosystem
- Packagist
- Packages
- concrete5/core
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-29
Affected packages
• Packagist concrete5/core: >= 9.0.0, < 9.1.0 → fixed in 9.1.0
• Packagist concrete5/core: < 8.5.8 → fixed in 8.5.8
Description
XSS in /dashboard/blocks/stacks/view_details/ - old browsers only. When using an older browser with built-in XSS protection disabled, insufficient sanitation where built urls are outputted can be exploited for Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 to allow XSS. This cannot be exploited in modern-day web browsers due to an automatic input escape mechanism. Concrete CMS Security team ranked this vulnerability 3.1with CVSS v3.1 Vector AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N. Sanitation has been added where built urls are output.
Related
Alias · CVE (1)
- CVE-2022-30120 XSS in /dashboard/blocks/stacks/view_details/ - old browsers only. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-30120 advisory
- https://hackerone.com/reports/1363598 web
- https://documentation.concretecms.org/developers/introduction/version-history/858-release-notes web
- https://documentation.concretecms.org/developers/introduction/version-history/910-release-notes web
- https://github.com/concretecms/concretecms-core package